Registration is now invite-only. Any user can make an invite, you need to create it here and give resulting link to someone to register.

About project

This module takes a list of CSS files and concatenates them, making sure to
honor any valid @import statements included in the files.

Following the CSS 2.1 spec, @import statements must be the first rules in
a CSS file. Media-specific @import statements will be honored by enclosing
the included file in an @media rule. This has the side effect of actually
improving compatibility in Internet Explorer, which ignores media-specific
@import rules but understands @media rules.

It is possible that feature versions will include methods to compact
whitespace and other parts of the CSS itself, but this functionality
is not supported at the current time.

Last commit

avatar
abondrov has added 4bb2343fc1
MassBuild#1257: Increase release tag

Files in

100644 | 53 lines (39 sloc) | 1.41 KB
%define upstream_name    CSS-Squish
%define upstream_version 0.10

Name:		perl-%{upstream_name}
Version:	%perl_convert_version %{upstream_version}
Release:	7

Summary:	Compact many CSS files into one big file 

License:	Artistic or GPL+
Group:		Development/Perl
Url:		https://search.cpan.org/dist/%{upstream_name}
Source0:	https://www.cpan.org/modules/by-module/CSS/%{upstream_name}-%{upstream_version}.tar.gz

BuildRequires:	perl-devel
BuildRequires:	perl(File::Spec)
BuildRequires:	perl(Test::LongString)
BuildRequires:	perl(URI)
BuildArch:	noarch

%description
This module takes a list of CSS files and concatenates them, making sure to 
honor any valid @import statements included in the files.

Following the CSS 2.1 spec, @import statements must be the first rules in 
a CSS file. Media-specific @import statements will be honored by enclosing 
the included file in an @media rule. This has the side effect of actually 
improving compatibility in Internet Explorer, which ignores media-specific 
@import rules but understands @media rules.

It is possible that feature versions will include methods to compact 
whitespace and other parts of the CSS itself, but this functionality 
is not supported at the current time.

%prep
%setup -q -n CSS-Squish-%{upstream_version}

%build
perl Makefile.PL INSTALLDIRS=vendor
%make

%check
make test

%install
%makeinstall_std

%files
%doc CHANGES README
%{perl_vendorlib}/CSS/
%{_mandir}/man3/*